Not the same anymore.... | The Legend of Mir
  • EXCLUSIVE NEW PLAYER EVENT
    The Legend of Skull Island

    Experience a unique starter adventure on Arcadia: trapped in the Mineral Mines alongside the Islebound Kin; a small clan if islanders who have been isolated since the emergence of a great fiery harbinger. As the village scribes uncover lost magic, new heroes are rising to power. Discover the legend of Skull Island and harness your power to save the islanders from certain doom.

    Embark on new quests and face exciting challenges with the Arcadia community. Forge powerful new characters for your account and earn some much desired Elysian Ore.

    ALL new characters are welcome!
    read more..
    Download Arcadia

Not the same anymore....

vexus

Active Member
Andy since your reboot my motivation has started slacking basically...before the reboot I had 0 lag and was running on 78fps now that has dropped to 68fps. Some might say that’s still good I agree but the issue is I have noticed this annoying issue since update...

When pressing “M” it’s not instant no more like before

When I use random teleport my belt takes that slightest delay to replace the RT

When I open a bundle it’s a delay...

It’s becoming annoyance and pissing me off. Can you just undo what ever you did in that update.

I have same Pc same connection same number of people at home.
 
I don't have these issues, only had the EM laggy bug same as everybody else... maybe its on your end like an overloaded internet usage at your house or something.
 
I don't have these issues, only had the EM laggy bug same as everybody else... maybe its on your end like an overloaded internet usage at your house or something.

Got even worse today...something ain’t right. And it’s happened to me only earlier today none in guild. I’ll reset and rewind pc maybe
 
Which reboot do you mean? A reduced FPS wouldn't affect bundles / 'M' response time so do not think they are related.
Let me know if you find anything
 
Which reboot do you mean? A reduced FPS wouldn't affect bundles / 'M' response time so do not think they are related.
Let me know if you find anything

After restarting pc and router things seem normal just the odd lag here and there. I changed my connection to 1gb so hopefully that will help much.
 
Back
Top