Not able to download latest mir.exe or patch | The Legend of Mir
  • EXCLUSIVE NEW PLAYER EVENT
    The Legend of Skull Island

    Experience a unique starter adventure on Arcadia: trapped in the Mineral Mines alongside the Islebound Kin; a small clan if islanders who have been isolated since the emergence of a great fiery harbinger. As the village scribes uncover lost magic, new heroes are rising to power. Discover the legend of Skull Island and harness your power to save the islanders from certain doom.

    Embark on new quests and face exciting challenges with the Arcadia community. Forge powerful new characters for your account and earn some much desired Elysian Ore.

    ALL new characters are welcome!
    read more..
    Download Arcadia

Not able to download latest mir.exe or patch

shadow

Active Member
Hello


I get this error when trying to download the latest mir patch or mir.exe

"http://www.mirarcadia.com/update/!klist.txt" Unable to connect.(98)


i tried running in admin mode and still no good.. any suggestions?
 
about 10 pages of data like this comes up

D 1993-10-08 13:12 735872:392978 CustomData\Mir3\Snow\SmTilesc.wil \CustomData\Mir3\Snow\SmTilesc.wil.gz 750078715
D 2105-04-14 09:43 988:795 CustomData\Mir3\Snow\SmTilesc.wix \CustomData\Mir3\Snow\SmTilesc.wix.gz 4269138195
D 2044-09-04 22:04 2036732:370910 CustomData\Mir3\Snow\Animationsc.wil \CustomData\Mir3\Snow\Animationsc.wil.gz 2356632228
D 1996-05-04 18:54 3384:2173 CustomData\Mir3\Snow\Animationsc.wix \CustomData\Mir3\Snow\Animationsc.wix.gz 831228824

i tried restarting my computer too
 
So, you are able to connect to that address but something is blocking the connection from the patcher to that address.
Usually this is where Firewalls get in the way but it can also be an antivirus program
 
So, you are able to connect to that address but something is blocking the connection from the patcher to that address.
Usually this is where Firewalls get in the way but it can also be an antivirus program

yes basically.. i haven't changed anything tho, i was logged on mir until the latest reboot. ill play around with windows see if i can fix anything but i doubt it.. ill try rebooting the whole computer before i just rebooted the VMware that i run on Imac


oh when logging on using the previous mir.exe it signs me in and shows a bit of activity in game before it kicks off saying client is out of date.. so the old version deff connects to mir just its not the latest..
 
Last edited:
It is the mir.exe patcher that is being blocked from making a connection to the patch server by something on your system.

Connecting to the game and connecting to the patch server are different things.

You need the latest Mir2.exe to play because of certain changes
 
cant figure this out... any recommendation..? can i download the mir.exe from somewhere else?

can somebody tell me if your update.ini is the same as mine.

[PATCH_FTP]
PROTOCOL=HTTP
LISTFILE=!klist.txt
SERVERIP=www.mirarcadia.com
BBS1=http://www.thelegendofmir.com/updater
BBS2=http://www.thelegendofmir.com/updater
BASEDIRECTORY=/update
PORT=21
USERID=anonymous
PASSWD=user@host.com
PASSIVE=FALSE

thanks
 
Last edited:
Temporarily disable antivirus and/or firewalls

i dont have any antivirus or firewall running... i have VMware that runs windows 7 only for mir, with most unwanted functions disabled like firewall or all sort of other services. cant even browse the web on it. its just purly for mir. i have managed to get hold of mir.exe and can now play.. maybe it will fix it self out.. but for now problem is fixed. thanks
 
Hello

Is there a port for mir patcher that i can punch into my router port forwarding section? this problem is creeping up on me slowly. another reboot today and now my other computer cant even connect to the patcher.. -_-
 
Port forwarding shouldn't be required. It patches over port 80, standard for web pages

ok thanks ill try to play around with that port 80.

note: the patcher opens, then closes and opens again with possibly different settings? u think that could be the issue Scorpian?
 
Last edited:
ok thanks ill try to play around with that port 80.

note: the patcher opens, then closes and opens again with possibly different settings? u think that could be the issue Scorpian?

Why would you need to forward anything? Port forwarding in your router is for incoming connections only, this is an outgoing connection.

Every webpage you visit over http is port 80 (https is 443)

If you can visit any webpage then you can connect to the patcher. I promise it's not a port forwarding issue unless you have some really crazy setup, in which case I'd love to know more and can probably help...
 
I am not sure why the patcher reboots but it is standard behaviour when it fails to do something it wants to. It's possibly just a retry effort

Do you have internet explorer? Does the broken link/address open in internet explorer?
 
internet explorer is disabled and has been for a long time.. so i cant even browse the net there.. might have something to do with this. but i never had this issue before..

In the end i had to copy and paste the whole mir from a computer that patches it. so im good for now. thanks for trying to help guys
 
Back
Top