Fried my computer, got new better one but now too laggy to play | The Legend of Mir
  • EXCLUSIVE NEW PLAYER EVENT
    The Legend of Skull Island

    Experience a unique starter adventure on Arcadia: trapped in the Mineral Mines alongside the Islebound Kin; a small clan if islanders who have been isolated since the emergence of a great fiery harbinger. As the village scribes uncover lost magic, new heroes are rising to power. Discover the legend of Skull Island and harness your power to save the islanders from certain doom.

    Embark on new quests and face exciting challenges with the Arcadia community. Forge powerful new characters for your account and earn some much desired Elysian Ore.

    ALL new characters are welcome!
    read more..
    Download Arcadia

Fried my computer, got new better one but now too laggy to play

So I was smoking in my kitchen the other day and accidently put the heat on so my computer melted while I wasnt paying attention, got a new one that is miles better but now the game lags so hard I cant really play. Last one was an i3 and this one is intel i7. Anyone know what I can try tweaking to fix it? Tried limiting FPS ingame but not much else. Any ideas?

- - - Updated - - -

So I was smoking in my kitchen the other day and accidently put the heat on so my computer melted while I wasnt paying attention, got a new one that is miles better but now the game lags so hard I cant really play. Last one was an i3 and this one is intel i7. Anyone know what I can try tweaking to fix it? Tried limiting FPS ingame but not much else. Any ideas?

Also on checking on activity the game is taking like 30-50% of CPU and memory
 
Is it a new or used computer? Hard drive seek times are quite a common cause of lag in this game so an aging disk could be a worthwhile thing to look at.
 
Depends what you mean about "lags so hard". Can you describe the lag? Which i7 is it?

Two-step lag is more of a ping issue - because you are not receiving the "okay, continue running" handshake fast enough
Random spikes could be a network routing issue, try a cable if on wifi as the signal may be struggling
Low FPS would be a CPU problem, as in low single clock speed or other apps using it
If there's a long pause, say, when you tt then it could be a disk issue, with it taking too long to locate the data to load into memory
 
Depends what you mean about "lags so hard". Can you describe the lag? Which i7 is it?

Two-step lag is more of a ping issue - because you are not receiving the "okay, continue running" handshake fast enough
Random spikes could be a network routing issue, try a cable if on wifi as the signal may be struggling
Low FPS would be a CPU problem, as in low single clock speed or other apps using it
If there's a long pause, say, when you tt then it could be a disk issue, with it taking too long to locate the data to load into memory
Thanks for the help, yep its extra problems when I tele, it stops working completely for 7-15 sec.

As for the laptop its some 0,99kg laptop with a touchscreen and unnecessary functions (not me who bought it)

Enhetsnamn DESKTOP-640C2HO
Processor Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz 2.39 GHz
Installerat RAM-minne 8,00 GB
Enhets-ID 228CE01E-A33F-4031-967C-4B8E05D82F8F
Systemtyp 64-bitars operativsystem, x64-baserad processor

Does this mean I need to change laptop to play?

Im currently at my gf's house so I will try again once I get back home to my landline.
 
Is it a new or used computer? Hard drive seek times are quite a common cause of lag in this game so an aging disk could be a worthwhile thing to look at.

Again thanks, I think its leaning towards being the issue

- - - Updated - - -

Depends what you mean about "lags so hard". Can you describe the lag? Which i7 is it?

Two-step lag is more of a ping issue - because you are not receiving the "okay, continue running" handshake fast enough
Random spikes could be a network routing issue, try a cable if on wifi as the signal may be struggling
Low FPS would be a CPU problem, as in low single clock speed or other apps using it
If there's a long pause, say, when you tt then it could be a disk issue, with it taking too long to locate the data to load into memory
Thanks for the help, yep its extra problems when I tele, it stops working completely for 7-15 sec.

As for the laptop its some 0,99kg laptop with a touchscreen and unnecessary functions (not me who bought it)

Enhetsnamn DESKTOP-640C2HO
Processor Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz 2.39 GHz
Installerat RAM-minne 8,00 GB
Enhets-ID 228CE01E-A33F-4031-967C-4B8E05D82F8F
Systemtyp 64-bitars operativsystem, x64-baserad processor

Does this mean I need to change laptop to play?

Im currently at my gf's house so I will try again once I get back home to my landline.
 
Depends what you mean about "lags so hard". Can you describe the lag? Which i7 is it?

Two-step lag is more of a ping issue - because you are not receiving the "okay, continue running" handshake fast enough
Random spikes could be a network routing issue, try a cable if on wifi as the signal may be struggling
Low FPS would be a CPU problem, as in low single clock speed or other apps using it
If there's a long pause, say, when you tt then it could be a disk issue, with it taking too long to locate the data to load into memory
Dont know why but my replies arent showing up
Yes I get enormous lag as i try to tele, just tried again and had to ctrl alt del just to exit game when i did a teleport

Enhetsnamn DESKTOP-640C2HO
Processor Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz 2.39 GHz
Installerat RAM-minne 8,00 GB
Enhets-ID 228CE01E-A33F-4031-967C-4B8E05D82F8F
Produkt-ID 00326-10000-00000-AA710
Systemtyp 64-bitars operativsystem, x64-baserad processor
Penna och pekskärm Stöd för touch med 10 tryckpunkter


Leaning towards it being a disk issue as someone earlier said. Again, thanks for the help both of you
 
Depends what you mean about "lags so hard". Can you describe the lag? Which i7 is it?

Two-step lag is more of a ping issue - because you are not receiving the "okay, continue running" handshake fast enough
Random spikes could be a network routing issue, try a cable if on wifi as the signal may be struggling
Low FPS would be a CPU problem, as in low single clock speed or other apps using it
If there's a long pause, say, when you tt then it could be a disk issue, with it taking too long to locate the data to load into memory
Dont know why but my replies arent showing up
Yes I get enormous lag as i try to tele, just tried again and had to ctrl alt del just to exit game when i did a teleport

Enhetsnamn DESKTOP-640C2HO
Processor Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz 2.39 GHz
Installerat RAM-minne 8,00 GB
Enhets-ID 228CE01E-A33F-4031-967C-4B8E05D82F8F
Produkt-ID 00326-10000-00000-AA710
Systemtyp 64-bitars operativsystem, x64-baserad processor
Penna och pekskärm Stöd för touch med 10 tryckpunkter


Leaning towards it being a disk issue as someone earlier said. Again, thanks for the help both of you
 
Enhetsnamn DESKTOP-640C2HO
Processor Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz 2.39 GHz
Installerat RAM-minne 8,00 GB
Enhets-ID 228CE01E-A33F-4031-967C-4B8E05D82F8F
Produkt-ID 00326-10000-00000-AA710
Systemtyp 64-bitars operativsystem, x64-baserad processor
Penna och pekskärm Stöd för touch med 10 tryckpunkter

Ok so my replies still aren't showing up?
Anyway would it help to run the game from another disk? Like a portable harddrive or something. My girl woke me at 7am this morning and really feel like playing Mir this morning while my girl does some work but I can't still. Any suggestions on how to fix this?
 
First check ur ant viruse and allow the game.
Second run game in Windows xp mode
Third run the game on ur external graphics card
And stop auto update for Windows and other programs if ur internet speed is low
All this if ur computer not have hardware/internet issues
 
Last edited:
What is the hard disk? I really wouldn't expect that to be the issue unless it was faulty. So maybe run some test on it, usually the manufacturer has software for that.

Maybe you can try running it from a USB external drive to see if there is a difference.
 
Enhetsnamn DESKTOP-640C2HO
Processor Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz 2.39 GHz
Installerat RAM-minne 8,00 GB
Enhets-ID 228CE01E-A33F-4031-967C-4B8E05D82F8F
Produkt-ID 00326-10000-00000-AA710
Systemtyp 64-bitars operativsystem, x64-baserad processor
Penna och pekskärm Stöd för touch med 10 tryckpunkter

Ok so my replies still aren't showing up?
Anyway would it help to run the game from another disk? Like a portable harddrive or something. My girl woke me at 7am this morning and really feel like playing Mir this morning while my girl does some work but I can't still. Any suggestions on how to fix this?

I was getting the same tele then freeze for 10-15 seconds issue with a new Dell XPS laptop (i7 (9750@2.60ghz), 1TB NVMe Intel SSD, 16gb RAM) after an Arcadia update.
The single biggest improvement I made was on my wireless card changing the setting 802.11 a/b/g setting under the advanced properties tab of the card from dual band 802.11 b/g to 2.4ghz b/g. My router doesn't support 5ghz and changing this setting improved the freeze and also speeded up my internet use in general. If you have a discreet graphics card like a GForce GTX 1650 you can tell Windows to use this card for certain programs under your display settings too.
I still get the freeze but it is not as bad as it was. I did make a forum post about this a few months ago when the issue occurred but everyone more or less said it was my laptop that was the problem (It had been working fine up until then).
 
The way you describe it definitely sounds hard drive related. Watch task manager to see what is using highest % of disk read capacity, maybe some AV is scanning the disk all the time, or windows update causing issues, maybe something else. But something is probably using the disk a lot, kill that and you might be ok
 
problem is your on laptop right.

if so its probably due to your most likely running the game in power saving mode.

go to windows search type > edit power plan - then click cancel - then click onto high performance mode.

Most likely fixes your issue, check this everytime.
 
problem is your on laptop right.

if so its probably due to your most likely running the game in power saving mode.

go to windows search type > edit power plan - then click cancel - then click onto high performance mode.

Most likely fixes your issue, check this everytime.

Interesting thought, may also be caused by the hard drive going to "sleep". Could possibly check that in power options and never let it power down
 
Interesting thought, may also be caused by the hard drive going to "sleep". Could possibly check that in power options and never let it power down

thats another reason yeah, but more then likely what i suggested as i had to do the above on my own gaming laptop as my FPS drop was very significant without it running in high performance mode.
 
problem is your on laptop right.

if so its probably due to your most likely running the game in power saving mode.

go to windows search type > edit power plan - then click cancel - then click onto high performance mode.

Most likely fixes your issue, check this everytime.

Yep checked that and have put everything on maximum settings and high performance mode. When I put the game on the CPU and Memory go up to about 50% and the fan starts running. The only suggestion I havent tried yet is SSD since I dont have one. :/
 
Yep checked that and have put everything on maximum settings and high performance mode. When I put the game on the CPU and Memory go up to about 50% and the fan starts running. The only suggestion I havent tried yet is SSD since I dont have one. :/
Have you looked at tweaking the network adapter settings as mentioned above to see if that helps?
 
Yep checked that and have put everything on maximum settings and high performance mode. When I put the game on the CPU and Memory go up to about 50% and the fan starts running. The only suggestion I havent tried yet is SSD since I dont have one. :/

Are all your drivers up to date?

If it is Windows 10 you can update them by checking for Windows Updates, maybe could be a driver conflict causing the high usage when running mir
 
Back
Top